1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Downloading the game (just no button after 4game Installation)

Discussion in 'Archive' started by Iluya, Dec 8, 2011.

Thread Status:
Not open for further replies.
  1. Iluya

    Iluya User

    Joined:
    07.12.11
    Messages:
    9
    Likes Received:
    0
    hi there,

    ive tried every bugfix for button-related problems i found. so clearing browser cache (with and without ccleaner), reinstalling with different options and different browsers (ff, chrome, opera). i also deinstalled my comodo firewall, as it seems it is related to some of the problems here. noscript-addon and even adblock is disabled on your site.

    so.. i see this: [​IMG]
    on the intall site. also the main start site (which should redirect me to either the install or the start site) isnt able to determinate which one i should go to. (5 mins waiting time)

    ive also tried to get a 4game log as one of the devs here wanted it. the registry-keys were correct (checked it in the editor), but no log files were created, which takes me to the conclution, that there is a problem in the connection between the browser-interface and the 4game software.

    os is an up-to-date win7.

    not direct related, but some "problems" i have with this whole launcher in browser thingy and the 4game software: 1st: this 4game software is requiring a specific c++ redistributable and isnt accepting the newest ones.. its just not installing when its on my pc.. which i really dont like, as im using those newer versions for myself.
    2nd: by using a browser-related log in and game start u might have some more control over your starting routine, but provoking one more big error-pool, which is very difficult to fix, as browsers are very individually set up. and tbh: when someone like to get around your starting routines he will...

    i appreciate every solution you might come up with. also just say which informations u might additionally need...

    edit: just found some error occuring on the main page (https://eu.4game.com/lineage2/):
    Code:
    $.jsonp is not a function (line 76 in ./b/jsl4g/l4g.min.js?2011.20.82
    
    $.jsonp({url:g.url,data:{callback:"ssjpc"},callback:"ssjpc",timeout:g.updateinterval*500,cache:!0,pagecache:!1,complete:function(){h("lastupdatetime",(new date).gettime(),(new date).gettime()+g.updateinterval*2);k(!1)},success:function(a){try{if(typeof a=="object"){for(var b in a){e[b]=!1;for(var c in a[b])if(a[b][c]!=0){e[b]=!0;break}}n()}}catch(g){f.notify("log","error "+g.tostring())}},error:function(){f.notify("log","maintenance off (no answer)");f._trytosetstate(f._getgamescollection(),"mnotmaintenance")}})
    
    edit2: also i got problems while downloading some js-files .. i dont know why, but those arent cached correctly for me... (http req is canceling with ns_error_document_not_cached) ... its also causing the error from edit1...
    https://eu-br.4game.com/jquery/jquery.jsonp-2.1.4.min.js
    https://eu-br.4game.com/tracker/tracker.js
    https://eu-br.4game.com/jquery/jquery.cookie.js
    https://eu-br.4game.com/ga/gat.min.js

    edit3: i could locate the problem even more: my browser cannot verify your certificate for those files.
    eu-br.4game.com:443 using an invalid security-certification...
    errcode: sec_error_unknown_issuer.
    (google translate says: the certificate is not trusted because no certificate issuer chain is specified.)

    (translation of the error only analogously as i get them in german ;) )

    some additional screens to that...
    [​IMG]
    first one: httpfox response...
    [​IMG]
    failing to authorize the certificate (as in edit3 described and translated)
    (ot: just lol... your certification comes from comodo.. and you got problems with their firewall)
     
    Last edited by a moderator: Dec 8, 2011
  2. Ceburekas

    Ceburekas User

    Joined:
    06.12.11
    Messages:
    22
    Likes Received:
    0
    - removed pick
     
    Last edited by a moderator: Dec 8, 2011
  3. anteriorbear

    anteriorbear User

    Joined:
    07.12.11
    Messages:
    4
    Likes Received:
    0
    me too..lol
     
  4. Iluya

    Iluya User

    Joined:
    07.12.11
    Messages:
    9
    Likes Received:
    0
    @ ceburekas: u sould get this pic edited... and use a new mail address and get a new account ;)
     
  5. MeHigh

    MeHigh User

    Joined:
    08.12.11
    Messages:
    9
    Likes Received:
    0
    same problem here. this is hilarious :))
     
  6. anteriorbear

    anteriorbear User

    Joined:
    07.12.11
    Messages:
    4
    Likes Received:
    0
    omg..they cant even help us :mad: i try to fix it since yesterday.
     
  7. bankeris

    bankeris User

    Joined:
    01.12.11
    Messages:
    74
    Likes Received:
    0
  8. Iluya

    Iluya User

    Joined:
    07.12.11
    Messages:
    9
    Likes Received:
    0
    1. i will not remove all c++ versions.. its just not possible, as then some programs wont work anymore.. but the installation of 4game is working.
    2. i already tried to install it into other folders.. even on my system partition... no other result.
    3. ff, chrome and opera all shows the same result!
    4. my software and os are up-to-date

    also i narrowed the problem down to a corrupt certificate they use for the js files from eu-br.4game.com:443.. i can only access them directly, but the http-requests will fail with this certificate...
     
  9. bankeris

    bankeris User

    Joined:
    01.12.11
    Messages:
    74
    Likes Received:
    0
    read my post again, and try 9.1 step. and i'm sure if you will uninstall all c++ versions and install ms visual c++ 2010 10.0.30319 which innoe gives, all your programs will work. it's almoust new version.
     
  10. Iluya

    Iluya User

    Joined:
    07.12.11
    Messages:
    9
    Likes Received:
    0
    java isnt related in any form.. 4game uses per json injected code with some jquerys.. both are javascript-related.. which has absolutely nothing to do with oracles java...but i have installed 1.5, 1.6 (update 29).. so there isnt the problem anyway...

    i need some specific versions of c++, cause i use them to programm for a special enviroment, that only supports this version. and it doesnt matter if i deinstall the other c++ versions, as they have nothing to do with my browser-server connection.

    just look at the screenshots i made..my problem is in the connection between the website and the server. it all breaks down to this certificate. with a proper certificate i would get the json file and with this the code will begin to work..
     
  11. bankeris

    bankeris User

    Joined:
    01.12.11
    Messages:
    74
    Likes Received:
    0
    try to delele browser cookies and all other stuff. and re-launch browser. or try install chrome just for test ;)

    [edited] forgot to mension, one of the reasons why i'm using chrome because with firefox were same issue on other pages, dunno why.
     
    Last edited by a moderator: Dec 8, 2011
  12. Iluya

    Iluya User

    Joined:
    07.12.11
    Messages:
    9
    Likes Received:
    0
    already tried that.. im usually using chrome.. just for debugging i like the ff add ons more ;) but same on chrome, ff and opera... also tried from another network... but u got me a idea.. i have to connect through vpn to the internet.. maybe this causes the certifications to fail.. but im really not into those certification stuff.. no offense against you, bankeris, but u giving those standard-answers i already tried out. in my case its related to some connection issues or certification issues. i already reinstalled my opera to test if its related to some special preferences i made.. but still the same result.
     
  13. bankeris

    bankeris User

    Joined:
    01.12.11
    Messages:
    74
    Likes Received:
    0
    well i'm not from support team so yes a lot of i dont know :) but lets continue, have you tryed to install certificate? as i remember there is an option near web link it must show like broken or smth like that, just press on ir and try to install.
     
  14. Iluya

    Iluya User

    Joined:
    07.12.11
    Messages:
    9
    Likes Received:
    0
    okay... my problem step by step:
    1. the box that contains the playbutton/installbutton/repairbutton/install-progressbar has all elements in it, when you load the page. the site determinates which one you see by some routines (first critical point)
    2. the page itsself is ssl secured and the certificate for *.4games.com is working fine. im getting all files from eu.4game.com but the ones from eu-br.4game.com failing.
    2.1 the files that i cannot get, are containing some crucial methods for the site (especially jquery.jsonp-2.1.4.min.js which is essential.)
    3. taking a closer look to those files from eu-br.4game.com i saw, that the certificate for *.4games.com isnt accepted by my browser.. (error message in start-post) and i cannot make an exeption for it. the error code i get (sometimes sec_error_unknown_issuer, sometimes sec_error_unknown_cert) indicates a corrupt certification for the site, which makes no sense, as it is for *.4games.com.. ive read in some forums, that there maybe some errors in the flag settings of the certificate or the chain of certificates...
     
  15. BladeOfChaos

    BladeOfChaos User

    Joined:
    08.12.11
    Messages:
    23
    Likes Received:
    2
    i have a similar problem. web didn't detect my game, (i have the previous installer uninstalled). if i follow one of the links below the detect page the update button doesn't appear.

    please support team work on it, i've some friends that receive the same error so it's a common problem.

    thx
     
  16. bankeris

    bankeris User

    Joined:
    01.12.11
    Messages:
    74
    Likes Received:
    0
    if problem in browser maybe try to reinstall it? and your ms visual c++ version 10.0.30319 ?
     
  17. Iluya

    Iluya User

    Joined:
    07.12.11
    Messages:
    9
    Likes Received:
    0
    i tried it with reinstalling opera.. but it hasnt work... i also know why: the certificates are locally saved for all browsers.. so it doesnt matter which one you use.. same problem. but i cannot figure out how to delete them and install them again... i saw one commodo certificate thats expired in 04/2010..
     
  18. Iluya

    Iluya User

    Joined:
    07.12.11
    Messages:
    9
    Likes Received:
    0
    okay.. i'm downloading now.. not sure, if it was caused by what i did or if 4game/innova did sth...

    1. what i did was clearing my ssl-cache (internetoptions / ?content? )
    2. i started the 4game-service manually from the mmc...

    can somebody with this error please try this one (2):
    press windows-key + r;
    type "mmc" (without ")
    press strg + m
    choose "services" and add them for your local computer
    close the dialog
    choose the services in main window
    klick "4game" in the middle
    "start the service" ( topleft of mid-frame )
    refresh eu.4game.com/lineage2
     
    Last edited by a moderator: Dec 8, 2011
  19. TheChrome

    TheChrome User

    Joined:
    08.12.11
    Messages:
    1
    Likes Received:
    0
    i had same problem, just starting 4game service solved it. thx! :)
    (now downloading) blah i was in 4game folder and was trying to start 4gameservice.exe. but i wouldn't thought that i should just run service.. silly me. they should add info about it.
    oh and you can go to control panel - administrative tools - services or ctrl+shift+esc tab services or just run: services.msc
    maybe it will be easier for others to do (i use win7 64b)
     
  20. anteriorbear

    anteriorbear User

    Joined:
    07.12.11
    Messages:
    4
    Likes Received:
    0
    help me..it doesn't wok for me...:(
    :eek:please:eek:
     
Thread Status:
Not open for further replies.