1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Epeisodion stuttering - interface

Discussion in 'Archive' started by BeerWarrior, Mar 12, 2014.

Thread Status:
Not open for further replies.
  1. BeerWarrior

    BeerWarrior User

    Joined:
    28.02.13
    Messages:
    156
    Likes Received:
    21
    hi, i updated the game properly, i logged on in dion, everything seemed to be fine until i noticed that stuttering was not stopping to occur after i moved and teleported a lot.

    update in the next post.

    wherever i was, be it open locations such as war-torn plains, closed locations such az zaken ship, or aden/giran towns, the game would keep stuttering randomly, 1 to 3 times a second, depends on how fast i turned my camera around.
    such problem never existed on tauti without ssd, on lindvior with ssd, the game still runs on the ssd (samsung evo) and it pisses me off as with the latest update it became unplayable.

    i tried to reset the settings completely, restarted the game, rebooted the pc, none of those fixed the issue.
    i tried everything, disabling chat transparency and its fixed size as well as other things, with no effect, but then i noticed it was perfectly playable after i disabled the interface (alt+h), which i never had to do before.
    since mainly the chat has changed, i tried disabling the chat only (alt+j) but that did not do anything, even with the interface enabled and the chat disabled it's unplayable.

    please note, i reset the settings completely, restarted everything, game updated, frost updated, 4game updated.
    the game runs on one of the best home ssds out there and it has never happened before, the issue slows down the loading of everything as well.
    before epeisodion whenever i disabled the interface (alt+h) i never noticed a difference in performance, since epeisodion the game is unplayable until i do so.

    please help, advise or something :|

    update. after investigating the issue even more i learned that it only happens when both, the interface is on, i move the cursor. as i said previously there's no problem when i move the cursor like i'm mad with the interface off.
    also it only happens when the mouse cursor is present in the game window and outside of the interface (over the game world).

    however, i also have a touchpad and there's no problem when i operate the game using touchpad with the interface on, but playing the game using touchpad is painful so it's not an option.

    i've read that changing the polling rate to a low value and using a cheap mouse helps, but i use a cheap usb mouse with quite low polling rate, problem persists.

    it looks like the problem is related strictly to the mouse and the interface.

    edit: further tests showed that my cheap mouse uses 125hz polling (quite low and still problematic) but my touchpad uses 75hz and it's all right.
    how badly do the game developers need to screw up this game with each consecutive update?
    do i now need to set my mouse polling to 75hz? yeah right, with next update they're going to add disco ball and more lights and fancy stuff and keep the damn ue2.5 engine from the year 2002. well freaking good job ncsoft.

    has anybody found a way around it?
     
    Last edited by a moderator: Mar 13, 2014
  2. BeerWarrior

    BeerWarrior User

    Joined:
    28.02.13
    Messages:
    156
    Likes Received:
    21
    just great, just freaking hilarious!
    today i spent about 5 hours researching the problem that the ncsoft developers caused, hoping i could play but no. no i can't. let me elaborate.

    turns out the problem relates to the polling rate of usb mice that defaults to 125hz, certified drivers do not let you change it.
    so you need to use unsigned drivers and test-sign them, that's not as simple on 64bit systems, but doable.
    so i sorted it out, i used a driver filter which i set 1 stage lower (a half, from 125hz to 62hz), i enabled test signing and i run my win7 in developer mode.

    frost won't let me in
    [​IMG]

    after a minute of searching the web i found this https://ru.4gamesupport.com/kb/articles/251-frost

    conclusion: ncsoft screws up, delays the fix and innova's product won't let me apply a legit workaround.

    apparently ncwest and lilith keep waiting for the fix, who knows when core is gonna get it, 3 months later, as per usual?
    that's how it all made me feel, thanks very much.

    [​IMG]
     
    Last edited by a moderator: Mar 13, 2014
  3. BeerWarrior

    BeerWarrior User

    Joined:
    28.02.13
    Messages:
    156
    Likes Received:
    21
    bump.

    i do believe ncsoft, ncwest and innova were aware of that bug long before epeisodion came to core. lf action.
     
  4. ImYourChrist

    ImYourChrist User

    Joined:
    28.01.14
    Messages:
    36
    Likes Received:
    1
    well, it seems to affect only couple of ppl, so no damn is given about it. if you think about it, its not really good business politics though. win7 he, laptop and mouse software is off. still micro freezes.

    someone who does own a logitech g600 and doesnt experience this issue pls pm me.

    updating drivers didnt help either, just to note.
     
  5. BeerWarrior

    BeerWarrior User

    Joined:
    28.02.13
    Messages:
    156
    Likes Received:
    21
    win7 x64 ultimate, toshiba laptop, no mouse software at all, cheap usb mouse with 125hz polling rate on default msusb drivers.
    no problem with ps/2 touchpad with 62hz polling rate. is usb the problem here?
    what the hell am i talking about, of course bad coding is a problem here cause it has never happened until the epeisodion/valiance.
    months after the epeisodion on the korean server(s) and months after valliance on ncwest servers, those newbs from korea couldn't bother to issue a fix to the problem. do you even debug bro?
     
  6. casillias

    casillias Technical specialist Innova Group

    Joined:
    05.04.11
    Messages:
    10,301
    Likes Received:
    534
    i regret to say, but so far korea made no steps forward these problems... mostly such problems occur on "smart" mouse but sometimes when polling rate on usb port is over 250hz it causes such freezes... all we can do is wait now... it's not an issue due to frost or innova believe me
     
  7. BeerWarrior

    BeerWarrior User

    Joined:
    28.02.13
    Messages:
    156
    Likes Received:
    21
    correct, however i tried to use custom mouse driver that allows to adjust the polling rate manually, test-signed, that requires the windows to boot up in test mode, in which it's fully functional and it does not change anything but the fact you can load test-signed drivers. frost does not allow l2 to run in windows test mode. thank you innova, i tried, i really have tried.
     
  8. casillias

    casillias Technical specialist Innova Group

    Joined:
    05.04.11
    Messages:
    10,301
    Likes Received:
    534
    you are not the only one who tried this method and yup you are right frost don't like windows being in test mode... if i'm not mistaken gg does not like test mode either... and please keep sarcasm with you, we are trying to solve this problem, but it all depends on korea and no one else...
     
    Rosenrot likes this.
  9. BeerWarrior

    BeerWarrior User

    Joined:
    28.02.13
    Messages:
    156
    Likes Received:
    21
    okay, got it. excuse the sarcasm, it's easy for you to say to keep it to myself. i've only learnt from polish 4game forums that they have requested a fix from korea, months after valiance was installed on ncwest servers where some people suffered from the same problem. so months after initial reports the issue has not yet been solved by the developers, so excuse me but now i feel like all the time i spent on building my characters here was for nothing because i can't continue to do so.
    not a single word from staff in my support thread dated 12th mar 2014 21:59, not a single word of hope.

    i'll just wait and see what happens.
     
  10. BeerWarrior

    BeerWarrior User

    Joined:
    28.02.13
    Messages:
    156
    Likes Received:
    21
Thread Status:
Not open for further replies.