1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Session issues

Discussion in 'Archive' started by Toto_l2, Jan 1, 2012.

Thread Status:
Not open for further replies.
  1. Toto_l2

    Toto_l2 User

    Joined:
    07.12.11
    Messages:
    19
    Likes Received:
    0
    hello, a few strange things about sessions and frost :

    1) one session is opened (user). when i launch the game with the play button, i a have an error : game loading error.

    2) one session is opend (admin). when i lauch the game with the play button, i have this error :

    2012.1.1 13:41:26
    os : windows 98 4.10 (build: 67766446)
    cpu : genuineintel intel(r) core(tm)2 duo cpu e8500 @ 3.16ghz @ 3169 mhz 3582mb ram
    video : no video
    poscode : ls9(415) 0:0:0 2/0 [524]

    assertion failed: getclassinfoexa( null, tchar_to_ansi(winbaseclass), &cls ) [file:.\window.cpp] [line: 1064]

    history: wcontrol::registerwindowclass <- uwindowmanager::uwindowmanager <- initwindowing

    i am runnig under windows xp sp3, not windows 98 !

    3) one session is opend (admin). when i lauch the game with a command line (using process explorer, frostoption 7), i can play 1 minutes before being disconected : you have been dc from the server.

    4) two sessions are opend (user and admin). i am logged with admin. i launch the game with the command line. i can play with no dc and enjoy the game.

    well, frost is a very weird stuff...
     
  2. Radix

    Radix Innova Group

    Joined:
    10.02.10
    Messages:
    6,061
    Likes Received:
    224
    1) admin rights are needed
    2) check "compatibility mode" on game binary files or game launcher (it's not frost issue with os-detection)
    3), 4) bad idea from you - it's banable (cmd-line launching) and gives a lot of security-logs on server

    let me know if your problem is persist after fixing compatibility mode on your pc and normal client-launch (not cmd)
     
    Last edited by a moderator: Jan 3, 2012
  3. Toto_l2

    Toto_l2 User

    Joined:
    07.12.11
    Messages:
    19
    Likes Received:
    0
    hello, radix, and thanks for trying to help me.

    you were right, one file, in frost folder, was in win98 compatibility. i have fixed it. now i can lauch the game with the play button. there is no error, i can log. but i have a dc in about one minute.

    so, i am afraid a have to continue to use te commande line.
     
  4. Radix

    Radix Innova Group

    Joined:
    10.02.10
    Messages:
    6,061
    Likes Received:
    224
    the better way -> give me your network logs (http://www.wireshark.org/download.html) from game starting to dc (any acc).
    i can to analyze your kick reason (it's frost kick for rules violation and should be fixed in your case).
     
  5. Toto_l2

    Toto_l2 User

    Joined:
    07.12.11
    Messages:
    19
    Likes Received:
    0
    good news, after a reboot, the play button works well and there is no more dc (and i am only logged on the admin session).

    thank you, radix.
     
  6. Radix

    Radix Innova Group

    Joined:
    10.02.10
    Messages:
    6,061
    Likes Received:
    224
    ok! i'm glad to hear this, toto_l2!
    but if you have any troubles with dc - just make wireshark logs for me (it's very helpful for dc-analysis)
     
  7. Kall

    Kall User

    Joined:
    24.11.11
    Messages:
    1,019
    Likes Received:
    0
    good day,

    you can see actual solutions and issues' statuses here.
    additional instructions could be found here.
    if you can't find a solution for your issue you always can ask for moving the thread back into the main branch.

    best regards,
     
Thread Status:
Not open for further replies.