1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Did anyone manage to run L2 Classic in a VM

Discussion in 'Archive' started by phrozenb, Dec 26, 2015.

Thread Status:
Not open for further replies.
  1. phrozenb

    phrozenb User

    Joined:
    19.02.14
    Messages:
    83
    Likes Received:
    52
    Hey guys,

    The game is working just fine on Windows, so no problems there, so I don't expect any official support.

    I have a hackintosh (a pc that can run both windows and OS x), and for work, I mostly use the OS X part. I'd like to be able to keep my shops online while I work, but I have yet to be able to run l2 classic on Parallels. I've tried Windows 7 / 10 (32 bit, 64 bit)

    The "this application cannot run in a virtual environment" is easy to overcome, if anyone wants details, send me a pm, I'm not sure that I'm allowed to post the solution here, but a google search should help you past that.

    I have been running the l2 Europe client for more than a year in a VM, with no problems, I can still run it now, but l2 classic client won't start.

    It keeps saying:
    I've tried Direct X 9 and 10, in the directx dialog it says that everything is enabled. I gave the video card 512MB of ram, the VM has dual core and about 4GB of RAM, and it's all located on a SSD.

    All in all, this should be running smoothly, but I can't get past the 3d not enabled error. If someone managed to overcome this, or if any of the technical staff has any ideas on how to fix this, any help would be greatly appreciated.
     
  2. Niewolnica

    Niewolnica User

    Joined:
    15.01.15
    Messages:
    80
    Likes Received:
    12
    I dont think you will get any help on running game on VM. As it is no problem on classic (subscription) , there is such on Core where boxes were limited. Maybe 3D acceleration is another form of blocking VM.
     
  3. phrozenb

    phrozenb User

    Joined:
    19.02.14
    Messages:
    83
    Likes Received:
    52
    Like I said, I have no problem running the latest version of l2 Europe. Only the classic version errors about the direct 3d.

    I know that the reason for adding said restriction was the premium accounts, but that is not applicable to l2 classic.
     
  4. Lindar

    Lindar User

    Joined:
    22.12.15
    Messages:
    1
    Likes Received:
    0
    I have the same problem. :-(
    I am waiting with you, maybe someone help us...
     
  5. lmnop

    lmnop User

    Joined:
    20.12.15
    Messages:
    30
    Likes Received:
    4
    Looking forward to this issue as well.
     
  6. Tussmörket

    Tussmörket User

    Joined:
    18.05.11
    Messages:
    6,373
    Likes Received:
    715
    L2 Classic use different options for Frost security, which always block such attempts.
     
  7. phrozenb

    phrozenb User

    Joined:
    19.02.14
    Messages:
    83
    Likes Received:
    52
    I actually managed to get it to run. There's an entire thread on the Innova's russian forums, which with a bit of google translate, explains how to do it.

    It's not easy, and I have to go through about 5 steps to get it to start, then 3 more steps to start the second client :(
     
  8. casillias

    casillias Technical specialist Innova Group

    Joined:
    05.04.11
    Messages:
    10,298
    Likes Received:
    534
    Out of date topic.
    Archived
     
Thread Status:
Not open for further replies.